Pleco for Android 2.3.4 Bug Report Thread

mikelove

皇帝
Staff member
Again, hoping there won't be too many, but we're definitely liking the fact that we don't have to wait a week for every new update to be approved as on iOS :)
 

uchihak

Member
Re: Pleco for Android 2.3.2 Bug Report Thread

Referencing the original complaint.
Hi Mike,
Unfortunately, it still doesn't load. I've upgraded to the 2.3.2 and even deleted the single syllable recordings. The extended recordings just won't play. I don't know if it's because I used the beta before the actual release?
Feeling a little frustrated, I'm almost tempted to physically come see you and show you my phone!

>>>>>
Hi Mike,
Actually I didn't even install the single syllable files originally as I was most curious about the tone sandhi which was the reason I bouht the extended audio in the first place. But Pleco kept on prompting me to download the single syllable files whenever I clicked on the little speaker icon so I got frustrated and gave in.
Can you tell me some common words for which Pleco definitely has extended audio recordings? I tried out da Lu as in Mainland which I figured is a fairly common word and got only the single syllable recordings.
Thanks!


That should be a valid one, yes. Try exiting Pleco, killing it completely via Task Manager or Settings / Applications, then reopening it; does the extended audio load correctly then?
 

mikelove

皇帝
Staff member
Re: Pleco for Android 2.3.2/3 Bug Report Thread

The single syllable recordings are required to play the multi-syllable ones - no way around that. So try this: delete all of the audio files, power your phone completely off and on again to make totally sure that Pleco isn't still running in the background, then reopen Pleco and re-download all four audio files.
 

quartzie

Member
Bug resolved report

Glad to see that enabling "Alternate video display" solved my problem with live video OCR on Xperia Ray.

Great job :mrgreen:

--quartzie
 

mikelove

皇帝
Staff member
Re: Pleco for Android 2.3.2/3 Bug Report Thread

JimmyTheSaint said:
The Chinese Market app still doesn't show the 2/5 update.
Sorry, it's up now - we're still fleshing out our procedure for building that version (automating the process of changing a couple of thousand references to our unique application bundle ID) which means that we have to do some extra testing every time we build it to make sure that we haven't broken anything.

quartzie said:
Glad to see that enabling "Alternate video display" solved my problem with live video OCR on Xperia Ray.
Great! Neat little phone - ergonomics-wise it's not exactly the form factor I'd recommend for running Pleco, but if you're primarily interested in OCR / voice / handwriting input (rather than keyboard) and don't mind the occasional missed attempt at tapping on a character in the document reader, it's a pretty slick little device. In fact, if you go by volume (rather than weight or length) I believe it would actually beat out the original HTC Touch for the title of Smallest Pleco System Ever.
 

cStyle

Member
I have a Galaxy Nexis on Verizon (CDMA) version in the US and the first two times i attempted to download the 26 MB data file my phone rebooted. However on the third try it downloaded fine and the application started.
 

cStyle

Member
cStyle said:
I have a Galaxy Nexis on Verizon (CDMA) version in the US and the first two times i attempted to download the 26 MB data file my phone rebooted. However on the third try it downloaded fine and the application started.
Sorry, just saw this was under the 2.3.4. This phone has version 4.0.2 of Android OS.
 

mikelove

皇帝
Staff member
cStyle said:
I have a Galaxy Nexis on Verizon (CDMA) version in the US and the first two times i attempted to download the 26 MB data file my phone rebooted. However on the third try it downloaded fine and the application started.
That's odd... when in the process did it reboot? In the middle of the download or as soon as it began?

cStyle said:
Sorry, just saw this was under the 2.3.4. This phone has version 4.0.2 of Android OS.
Actually version 2.3.4 of Pleco, though we should probably try to get away from common Android OS version numbers in our app :)
 

cStyle

Member
mikelove said:
That's odd... when in the process did it reboot? In the middle of the download or as soon as it began?
First reboot was about 5 seconds after the download started (about 6 MBs downloaded over 4G) and second reboot was immediately after launching the plecodict program. I have heard that the Nexis software is still a little buggy as it is close to bleeding edge and has not yet got the 4.0.4 bugfixes, so this could be more my phone and less your program.

mikelove said:
Actually version 2.3.4 of Pleco, though we should probably try to get away from common Android OS version numbers in our app :)
Funny!
 

leynux

举人
When I select "enable night mode"(white on black mode), on READER there is no highlight on selected text as in normal mode.

in normal mode, the selected text is in "orange".
 

mikelove

皇帝
Staff member
cStyle said:
First reboot was about 5 seconds after the download started (about 6 MBs downloaded over 4G) and second reboot was immediately after launching the plecodict program. I have heard that the Nexis software is still a little buggy as it is close to bleeding edge and has not yet got the 4.0.4 bugfixes, so this could be more my phone and less your program.
Possible, but we've got the same phone here and haven't seen this problem, so I'm wondering whether it's something specific to your internet connection... where are you located? Are you connecting via a cellular data connection or a WiFi network?

leynux said:
When I select "enable night mode"(white on black mode), on READER there is no highlight on selected text as in normal mode.

in normal mode, the selected text is in "orange".
Quite right - very good catch, thanks!
 
Top