Can't find batch edit mode

Hello, so i have a list of words i need to know, and i want to study them with chinese definitions. I wanted to import those words in Pleco, and then add the chinese definition into all these words, and it seems i can do that with the batch command that is referenced here

... but i can't find it ! When i edit cards, i have all the options like shown in the picture, except the batch one. i don't know what to do, manually making the cards for all these words will be a nightmare and its the main reason i want to use pleco

thank you very much
Hello vaanen,

importing a list with one Chinese word per line into Pleco while automatically adding Chinese definitions to it is fortunately a standard task; all you need to do is activate “Dicts only” or “Prefer dicts” in the Import dialog, and “Fill in missing fields”:


If you’d rather not import the same list twice, you should be able to reach the batch dialog from here:


Finally, you can remap the cards to the dictionary you would like them to point to:


Hope this helps,


PS: @mikelove Do you mind if I keep answering Pleco questions, would you prefer to answer them yourself? I would absolutely understand, I just enjoy doing that sometimes. :)
Last edited:


Staff member
@Shun - yes, very happy to have you help on that :)

@vaanen - if the batch command is missing it might be because you only have the free demo version of Pleco flashcards; 'batch' is only available in he paid version. If you don't want to upgrade to that version, go into Settings / Flashcards, erase your flashcard database, then reimport the file with dictionary matching per @Shun's suggestion.
ahh okok i didnt know it was a paid feature. glad to know that ! ill be paying anyway because i need the chinese dictionnary, but i wanted to try if that was possible before and i was worried i was jot seeing the batch command.

thank you very much !