floating-button/OCR

#1
Hello

I use Nexus-7 with Android 6.0.1

And I use the floating-button/OCR ... always.

Every few weeks I don't see the floating-button on my Nexus-7.
They are gone.
I must check "all" settings in system & in Pleco.
I "touch" all relevance setting ... etc. ... until .. the floating-buttons appear again.
Till next "trouble"-time ... :-(

Why .. this "trouble" ...?
What could I do?
Thank you.
 

mikelove

皇帝
Staff member
#2
Does it help if you switch to having Screen OCR in a notification instead of / in addition to as a floating button? That might make it less vulnerable to getting randomly terminated by Android.
 
#3
As long as I can activate/touch the "below-button"/OCR within any text/PDF reader ...
I think .. the floating-button is the only option to do that.... (?)

And .. the floatig-button is not "stable".
 
#5
Can you post screenshots to show me what/which is a "notification" .. and how to create and to use it.
The end goal must be the same. I don't care about the ways to the end goal.

(I'm confused because of the many names of software solutions ..)
Thank you.
 

mikelove

皇帝
Staff member
#6
Notifications = the things you get when you swipe down from the top of the screen; incoming messages, emails, notices about app updates, that sort of thing.

Turn off 'don't show notification' in Settings / External Access, if it's not off already. With that turned off, you should see a "Pleco Screen Reader" notification along with other notifications in the notification shade.
 
#7
Oh .. I see ..
At this very moment I have both:
1. Notification
and
2. the floating-buttons
on my Nexus-7

Wenn I read in an ebook China characters .. then I can touch the below-floating-button to activate Pleco and see the translation of characters ...

But at that moment the notification doesn't help me .. because I cannot see the notification. Sweeping can change the reader.
 
#9
Yesterday I got Pleco 3.2.60.

As I opened my Nexus-7 I saw No floating-buttons and No notification.
Fortunately .. in the past I've created "Screen Rea.." widget. I pressed on it.
Voila! .. both notification & floating-buttons appeared .. until now.

But .. in the past .. I pressed that widget .. nothing happened. :-(
But .. with perseverance .. the floating-buttons appear (again) .. at last.
 
#11
I have recently had issues with this too, hence coming here to search.
I've been using the notifications for a long time, and in the last week or so, it has has become very flakey.
(a) As I said, I normally use notifications instead of the floating box, but after I activate either OCR or Screen reader, it sometimes switches itself to notification. i.e. when I close the reader, I have a floating button instead of a notification. I'm not 100% if that happens with both Screen Reader or OCR or just one.
and much more annoyingly...
(b) The Screen Reader service keeps stopping. It used to happily sit there for days/weeks, for use whenever I wanted it.
Now, it only seems to sit there for an hour or two at max, and then Android appears to close the service. I have to continually switch to Pleco, activate Screen Reader/OCR, then select Screen Reader from the Notification bar, then it tells me the service has stopped. Then I have to go to the settings, turn it off (confirm), then turn it on (confirm) to get it back. I thought this might have been an issue with my phone, but since reading this, wondered if it might be a new issue with Pleco.
 

mikelove

皇帝
Staff member
#13
@garyt - what brand/model of Android device are you running and which version of Android is it running? If it's a Chinese brand, is it an international version of Android (with access to Google Play) or a proprietary Chinese version (which can only access that brand's app store and maybe a couple of other Great-Firewall-friendly ones)?
 
#14
Hi, @mikelove - It's a Meizu Redmi 5 plus, Android 7.1.2, MIUI 9.6.4. Yes, Internationalised with Google.
It's about 5 months old, from memory, and has lots of memory, if that is relevant. Thanks.
 

mikelove

皇帝
Staff member
#15
Check your system settings - is there a feature there to manage app power usage or memory or otherwise do something to confine / limit running apps? (I believe MIUI has had a couple of variations on that over the years) Turn that off if so, at least with regard to Pleco.
 
#16
Under settings/Battery/Battery Saver - Choose Apps, I set Pleco to 'No restrictions'. I guess it was the default 'Battery Saver' before, but didn't take note properly. I couldn't see any other settings. That was last night. This morning, the notification was gone again. I'll leave it like that and check if it's still the same.
 

mikelove

皇帝
Staff member
#17
It looks like some newer versions of MIUI ship with a feature called 'memory optimization' hidden in developer settings which also auto-kills background apps; go into developer settings and disable that feature and that should hopefully fix this.

If you don't see any developer settings in the Settings screen, go into the About section and tap on 'MIUI Version' 7 times and that will get them to appear.
 
#18
Hello

I use Nexus-7 2013(2) - Android version 6.0.1 ... from Asus
I've also the problem .. sometimes the notification disappears .. and appears again.
I live in Germany.

Einstellungen -> Entwickleroptionen -> Hintergrundprozesslimit
System Setting -> Developer-options -> number of background apps.

Hintergrundprozesslimit
o standardlimit -> default setting
o keine Hintergrundprozesse - no background process
o Höchstens 1 Prozess - at most 1 process
o Höchstens 2 Prozess - at most 2 process
o Höchstens 3 Prozess - at most 3 process
o Höchstens 4 Prozess - at most 4 process

I don't know what's standardlimit.
What option must I choose?
Thank you.
 
#19
Hi dxcarnadi,

I would first try it with the maximum "höchstens 4 Prozesse". If the problem goes away then, you could try progressively lower settings until the problem returns, then pick the last setting where it worked. The trouble is, the number of tasks running in the background usually isn't constant. So one day, a setting of at most 1 or 2 processes may be enough, and another day, even "at most 4 processes" won't be sufficient.

If you're not too concerned about battery life, you could just always leave it at 4 processes and then get access to the floating button perhaps 80-90% of the time. It would be the safest option. I have no idea what the "Standardlimit" could be.

Regards,

Shun
 
Top