Screen OCR stopped working on S10 (Solved)


When I click OCR cast icon, a pop-up message "Start recording or casting with Pleco? etc." shows up with option to click start now. After clicking start now, the pop-up closes and reopen with the same message constantly in every app except for Pleco. It used to work a few months ago.

Only if I click the cast icon in Pleco app itself, then OCR with green box shows up but if I switch to any other app, it stops working.

Device is Galaxy S10 on Android 11 One UI 3.1 with Pleco Accessibility enabled and gestures turned off. All phone settings are the same as it was when it used to work. Have already tried to restart phone and reinstall app.


Staff member
It sounds like your phone might be terminating our app as soon as it goes into the background, which is a common enough problem that somebody actually made a website about it - OEMs keep coming up with their own systems for background app killing (I imagine to squeeze a few extra minutes out of battery life testing so they look better in reviews) and not making those transparent to developers and Google seems unwilling or unable to rein that in.

Anyway the details on how to disable this on a Samsung phone with Android 11 are at: