TTS stopped working

#1
Hi,I'm new to Chinese, Pleco, and this Forum so let me first start by saying thanks for this amazing app :)

About a couple of weeks ago, TTS stopped working for both headwords (that don't have an audio recording) and for example sentences. the play button is there, but tapping it doesn't do anything.

I bought Qiang in the hope that this will fix it, but I now realize this is just a "voice" and not a different TTS engine (1: is this correct?).
Google TTS works fine elsewhere on my phone: well, at least where I tried it which is in google translate. in Fact, it also works fine in Pleco for the English translations of the example sentences when I "Enable English" . it just doesn't work for Mandarin.
my settings:
TTS Speed: 100%
System TTS Engine : I tried both "None" and "Google Text-to-Speech Engine" , neither works (2: what's the difference, Qiang appears in either case?)
in Android's system TTS settings:
- Preferred Engine: Google Text-to-Speech Engine
- Language: Chinese (China)
TTS Voice: Qiang (Mandarin Male), although it doesn't matter if I choose something else.
Hide example button: unchecked
Enable English: checked.
Volume: all 4 set at 100%


I am running Pleco 3.2.68 on Android 9.

3: Any idea what's going on here? I hope it's not something obvious that I'm missing!

Bonus question 4: Even when TTS was working, the character highlighting in sentences was wayyyy out of sync with the TTS. The highlighting moved faster and it seems this didn't change if I change TTS Speed. TTS Speed in pleco itself seemed to have no effect either, and I could only change the speed via accessing Android's setting screen for TTS.

I tried to lay out the problem as clearly as possible to help you help me, and hope I wasn't being unnecessarily long-winded ;)
 

mikelove

皇帝
Staff member
#2
Qiang is a different engine, so I'm not sure why that one wouldn't be working - are you sure it's the only one you've enabled? Does it help any if you reboot your device? Did you download the basic version of Qiang or the enhanced / high-quality one? (both included in the same purchase, just a question of which file you tapped on)

(let me know if you'd like a refund of that purchase)

As for system TTS, if you play a sample of Chinese audio in the System TTS Settings screen, does that audio play correctly? I believe Google Translate actually gets its Chinese audio from a separate system on Google's servers rather than from Google TTS, so the fact that Chinese works there does not necessarily mean it will work elsewhere on your system. We've seen more complaints than usual about Google TTS which appear to have in common that they're people located in China using a VPN - this has gotten considerably less reliable in the run-up to National Day and so if that describes your situation it may be that Google TTS can't download data for Chinese because it can't reach the relevant server.
 
#3
Ok, this is a bit embarrassing but a reboot of the device did do the trick!! I'm sorry but it just didn't occur to me to try that and trust me I tried EVERYTHING else.

Just to answer your other questions in case it's of any help to others reading this:
- I'm using high-quality Qiang, and no I don't want a refund. Pleco is wonderful and I've been super happy with all the add-ons I've purchased to date!
- Before the reboot, google TTS worked when playing a sample of Chinese audio in the System TTS Settings screen but not in Pleco.
- After the reboot, both Google TTS and Qiang started working again in Pleco, so this doesn't seem to be a TTS Engine specific issue I guess, but rather some Android OS problem ?
- Yes I am behind the Great Firewall running a proxy that uses ShadowSocks. it is true that proxies that run on other protocols are starting to experience issues in the run-up to National Day, but ShadowSocks seems to be spared (for now!). In any case, Google TTS works for me even with both data and wifi off so I'm guessing I must have downloaded Chinese language data at some point in the past.

Thanks for your help!
 
Top