Pleco for Android Beta 5 Bug Report Thread

mikelove

皇帝
Staff member
You know what to do. We'd love to hear about any previously-reported bugs that are still present in Beta 5 as well. Thanks!
 
As I mentioned, it seemed to delete my custom dictionary entry. Perhaps because it was for a character that doesn't exist in any of the other dictionaries? I did the update from the url download, and then told it to download the other updates (except for ABC Chinese-English dictionary). I haven't updated that dictionary yet. It seems it didn't get automatically downloaded with the other updated files (there were around 21 files according to the progress bar.)

Installing the update changed the Popup Definition unknown word handling back to the default, rather than my selection of Custom Dict Entry.

*** Update ***
I found that when I go to lookup history, select the character, it doesn't show up at all. (It should have shown up with my user dictionary entry, as stated above). Instead, it says "This entry appears to have been deleted from the dictionary." when I select the USR dictionary. For other dictionaries, I seem to just get the first word in the dictionary, which doesn't match at all.
 
I got a prototyping screen, with "Button 1", "Button 2", and "Button 3" and some text (not recalling exactly). Something like "Definition Text", and one other line.

Happened after downloading and trying the character stroke demo. I tried pressing the bottom to see if I could switch characters (nothing happened), and then I think I hit the "back" button (bottom left).

ASUS TF101
 

mikelove

皇帝
Staff member
stephanhodges said:
As I mentioned, it seemed to delete my custom dictionary entry. Perhaps because it was for a character that doesn't exist in any of the other dictionaries? I did the update from the url download, and then told it to download the other updates (except for ABC Chinese-English dictionary). I haven't updated that dictionary yet. It seems it didn't get automatically downloaded with the other updated files (there were around 21 files according to the progress bar.)

No, it's a separate updater that only applies to the "basic" data files (the ones we download when you first run Pleco), though we probably should rewrite the text to make that clearer. Did the entry actually disappear or did it just disappear from history?

stephanhodges said:
Installing the update changed the Popup Definition unknown word handling back to the default, rather than my selection of Custom Dict Entry.

Well that's odd... were any of your other settings reset?

stephanhodges said:
I found that when I go to lookup history, select the character, it doesn't show up at all. (It should have shown up with my user dictionary entry, as stated above). Instead, it says "This entry appears to have been deleted from the dictionary." when I select the USR dictionary. For other dictionaries, I seem to just get the first word in the dictionary, which doesn't match at all.

Yeah, it sounds like something in the update is pulverizing people's histories... we're working on it, but it's unrelated to your user dictionary entry disappearing.

stephanhodges said:
I got a prototyping screen, with "Button 1", "Button 2", and "Button 3" and some text (not recalling exactly). Something like "Definition Text", and one other line.

Happened after downloading and trying the character stroke demo. I tried pressing the bottom to see if I could switch characters (nothing happened), and then I think I hit the "back" button (bottom left).

That one's just a simple crash, should be easy to fix - thanks.
 

Shadowdh

状元
one thing I have noticed is that my add-ons list is asking me to re download all the add ons that are in the file already... do I have to redownload or just recopy the files across from the large one I have already downloaded? also its telling me that I need to purchase the pocket oxford but I already have... do I need to reload my key/serial number possibly?
 

Shadowdh

状元
ok I used the manage registration to activate the oxford dictionary... but its still showing I need to download all the files again even though they are on my device...
 
So far, the only other thing that was "deleted" was all of my bookmarks. But, perhaps I didn't understand how it worked in beta 3. I had bookmarks on file "A", and had loaded file "B" to read before the update.
 

mikelove

皇帝
Staff member
Shadowdh said:
one thing I have noticed is that my add-ons list is asking me to re download all the add ons that are in the file already... do I have to redownload or just recopy the files across from the large one I have already downloaded? also its telling me that I need to purchase the pocket oxford but I already have... do I need to reload my key/serial number possibly?

Shadowdh said:
ok I used the manage registration to activate the oxford dictionary... but its still showing I need to download all the files again even though they are on my device...

So the add-ons are showing up under both "Paid' and "Installed"? Could you maybe send me a screenshot of this? Very odd behavior... are they actually accessible in Pleco (so it's clear that the Add-ons screen is wrong) or is there a chance that they might have actually been deleted somehow?

stephanhodges said:
So far, the only other thing that was "deleted" was all of my bookmarks. But, perhaps I didn't understand how it worked in beta 3. I had bookmarks on file "A", and had loaded file "B" to read before the update.

Bookmarks should be retained for both files, and we actually didn't really change the format of those in the new beta... do both files show up in the "recent files" section of the bookmarks screen? That's tied to the bookmarks system - it lists files for which the system has valid bookmarks (even just the unlabeled "last place in the document" bookmark), in descending order of how recently you accessed them.
 
It only showed one file after the update to beta 5, the last one I had been looking at. That one wasn't the one with bookmarks. I've since reopened 3 or 4 files (mostly to see it working). No bookmarks anywhere. It's not a big deal. Might be more of a deal in the next upgrade, once I get used to it. I'll have to look and see if there's a way to export/backup the bookmarks and file list, etc.
 
Hi, Mike. Stupid number 1 here. I launched the apk but had trouble downloading the 24.5mb file so decided to leave it for afterwards. But i forgot to read the instructions on how to do so. Even more stupidly, I relaunched the .apk twice to see if I could try downloading thowe through pleco again. Apparently :? that hasn't affected anything. At least I hope so. Could you shed some light? Also, why aren't the updates for those 3 apps done internally through pleco?
 
I moved this issue to the beta 5 post since i updated to the latest version to see if took care of the problem. I am still having the issue of being in organize cards, in a specific category, scrolling and then going into a forced close situation. However this time i attached the log file as requested. I am kind of unfamiliar with the logging process. Hopefully i got it right, thanks
 

Attachments

  • 2011-12-04-07-39-19.txt
    102.4 KB · Views: 689

Shadowdh

状元
mikelove said:
Shadowdh said:
one thing I have noticed is that my add-ons list is asking me to re download all the add ons that are in the file already... do I have to redownload or just recopy the files across from the large one I have already downloaded? also its telling me that I need to purchase the pocket oxford but I already have... do I need to reload my key/serial number possibly?

Shadowdh said:
ok I used the manage registration to activate the oxford dictionary... but its still showing I need to download all the files again even though they are on my device...

So the add-ons are showing up under both "Paid' and "Installed"? Could you maybe send me a screenshot of this? Very odd behavior... are they actually accessible in Pleco (so it's clear that the Add-ons screen is wrong) or is there a chance that they might have actually been deleted somehow?

Hi Mike, apologies I should have been more clear, they are showing only in the paid (or free for the free add ons) lists. nothing excepting the writing and two others are showing in the installed list... the files I have on my sgs2 are the ones I have downloaded (from the large file you put up for those with slow download speeds) and put on the sd card as with beta 3 (and they all showed in the installed list)... they all showed up fine with beta 3 but are showing as not yet downloaded (thus not installed) on 5...
 

bomze

Member
Hey guys. Just installed Beta 5 on Samsung i9000, CyanogenMode. The 3d one worked well. But the 5th got some trouble: when you input a hieroglyph, almost all screen becomes black with only little white area on the right upper corner. When you press the corner whole screen becomes clear and you can read a word article. I tried to take a screenshot but strangely the screenshot are OK, you can read article without some dark area on it.
 
When i am in the flashcard program and practicing, i go to the writing screen and I am experiencing a forced close. I have attached the log, thanks
 

Attachments

  • 2011-12-06-06-28-06.txt
    98.5 KB · Views: 645

skripp

举人
I'm having the same problem as bomze. After writing a character and going to the definition list, most of the screen (the part with the definitions, at least) becomes black. You can still click on the items, but you can't see them. If you chose an item the problem goes away and if you press back you can see the entire list. Same thing if you turn of the screen and turn it on again, magically works again.

Sony Ericsson Xperia Arc with Cyanogenmod 7.2
 

Shadowdh

状元
ok was playing around with the file explorer on my phone and discovered that pleco now uses my external sdcard as the source and that the files are NOT in that part which I am rectifying now... so will prob be fixed when I put the files in the right folder oopsie :oops:
 

Shadowdh

状元
ok it was the files in the wrong place... then I had to transfer the modules into the other module folder in the android/data/ etc not sure if I have all the bits in the right place yet... there were two p2cedict-extindex.pdb files one that was 12.8mb and one that was 17.2mb not sure which is the latest? getting there slowly :)
 
When I use the OCR Launcher, look for something and then close Pleco, the OCR Reader still comes up first thing when I want to open Pleco normally. Don't know if it's intended.
 

benzhen

进士
the volume key scroll, while a very welcomed addition, overshoots by about half a line. the line of text that is off the screen before clicking with the volume key ends up being cut off after the scroll.

also when using the Reader shortcut, it only works if you have used the back button to exit the app. So if you hit home directly from the reader and hit the Reader shortcut to reenter, you get the dictionary screen.

*edit*: The auto-bookmarking feature is rather buggy. I had this issue in beta 3. Sometimes, and this especially happens if i dont back out of the reader, my most current spot is forgotten and it goes back to my last saved position. sometimes it goes back to the beginning. i'm not very knowledgeable about android development but i think it has something to do with different events triggering the save function. like instead of saving only on exit, it needs to save on lose focus or whatever as well.

these little bugs make my main use of pleco a bit of a pain. always losing my spot and having to remember to exit correctly and stuff. i just want to use it because i love how it looks and feels otherwise.

also it would be nice that when you hit open file, you end up back in the directory you were just in, not the root of the sd.

THANKS!
 
Top