Pleco on Windows 11 via WSA


I am aware there are topics that deal with running Pleco on the desktop (i.e. using Bluestacks), but I could not find a thread that deals specifically with the new Windows Subsystem for Android (WSA) on Windows 11.

WSA as installed via the Microsoft Store currently only allows installation of Android apps via the Amazon store which as of now only contains a small list of curated/tested apps.

However, the Google Play Store can be fairly easily be installed using the method described here:

Pleco installs without issues, below functions work just fine:
- dictionary entries, stroke order, etc.
- still OCR (don't have a webcam to test Live OCR)
- flashcards and user dictionaries
- resizing the app

What does not work:
- the popup definition (that opens after tapping/clicking on a character) causes Pleco to crash (regardless if the tweak "Force software rendering" is enabled or disabled)

- handwriting input, well it does work, but there seems to be an issue with the stroke display area

One step closer to Pleco on the desktop


  • Image 3.png
    Image 3.png
    469 KB · Views: 134


Thanks for the useful summary. It matches my experience sideloading the APK file to WSA.

The most unfortunate part is that the pop-up definition crashes the app, which makes the reader pretty much useless. Enabling the 'Force software rendering' option prevented the app from loading at all and I had to reinstall it.

FWIW, I have tried different APK versions and none worked. The older versions did not move past the installation of the packages -- it always failed.

Hopefully there will be a workaround soon. I'm very excited to use Pleco on desktop.


Indeed, perfect summary. I can confirm all of the above. On the positive side, I'd like to add that the clipboard works flawlessly, also for Chinese characters, both within the app and between WSA and Windows, whereas this usually is an issue with other emulators. And it seems that WSA is much more stable and less of a resource hog than the alternatives when it keeps running for a long time; everything seems really smooth.
While I definitely lack the skills, it would be great if someone could figure out a way to fix these two issues, i.e., handwriting and pop-ups.

An idea for a possibly very simple workaround: I could imagine that it might be fairly easy to add an option that just skips the popups and just opens the dictionary for the new word directly, which is usually done via the arrow-in-a-square button. If this avoid the crashing, that would make Pleco on WSA very usable already.
For handwriting input, the Windows handwriting input quite good in fact. Not as nice as the function integrated in Pleco, though.
Last edited: