Two Small Bugs Inside the Pleco Document Reader


first of all: Great App! I love the clip and file reader features and use them all the time to read and quickly lookup vocabulary in news and books. I haven't found any better program for that, especially on the phone. There are just some two minor bugs I came accross, which are acceptable but a bit annoying:

  1. Current Page is Lost When Switching Between Vertical and Horizontal Mode too Fast
    • Lets say I am in on some page inside a certain chapter. I accidentally move my phone in a way that it switches from vertical to horizontal mode. Then I quickly adjust my hand so that the phone changes back to vertical mode. But afterwards I am somehow on the first page of the same chapter.
    • Note that this problem does not occur if I perform these orientation changes slowly.
  2. Arrow Keys Stop Working After Tapping on a Word
    • After opening the reader, I can use the arrow keys of an external keyboard to switch pages. When I tap on a word with my finger to show the definition, there is no response when using the keys. Doing the same thing inside the reader lets me select the next word and show its definition.
    • After closing the definition, there is also no response to the arrow keys for page switching. Only after switching to another functionality inside the burger menu, I can go back to the reader and use the arrow keys for page switching again.
I whish these bugs can be solved. They are occuring on my Asus Zenphone 9 running Android 13. Please let me know if any more information is needed.

Best regards,
I originally experienced the problem with externally loaded .epub files. Now I just tried it with one of the graded reader demos from the pleco shop and it behaves exactly the same.