'Chinese History' won't open

#1
I've downloaded the demo version of the ebook, but when I attempt to open it, the system kicks me out of Pleco to the system home page. It doesn't crash the app per se, as Pleco is still open in the background; the book just doesn't open. My device is an Amazon Kindle Fire 5th Gen, running FireOS v5.6.1.0 (updated 2 Apr 2018) and Pleco v3.2.60 (updated 29 Jun 2018). I also just recently reinstalled Pleco, so I don't think that shouldn't be the issue. Any ideas?

BTW, and I'm not sure if this is related or not - I attempted to convert the demo to a more portable format using calibre E-book manager and it failed due to an issue with the base file's metadata. Thanks!
 

mikelove

皇帝
Staff member
#2
That's odd... where are you opening it from? The 'reader' command in the sidebar menu, or the "Add-ons" page?

Our data files use a Palm .pdb extension (still!) but they're not in one of the common Palm e-book formats and would not be openable by Calibre.
 
#3
I'm opening it from the reader command in the sidebar menu. Calibre says it can import .pdb files, although I don't know that I've tried to convert another one before this.

Update - so I just tried to convert a different .pdb file, and that one failed, too, with a similar-looking error (I didn't dig really deeply into the details). So that may be a separate issue.
 

mikelove

皇帝
Staff member
#4
Hmm... might be a crash, then. Is there a 'take bug report' command in the settings on Fire OS? If not, could you email or PM me with your Registration ID?
 
#6
I decided to go back through the calibre error message, and I think the key problem is here:

calibre.ebooks.pdb.PDBError: No reader available for format within container.
Identity is P3DBPLEN. Book type is Unknown


So I'm guessing "P3DBPLEN" is a .pdb variant of some type that calibre can't deal with. The same error message for the 2nd file I tried had a completely different "Identity" listed, so I suspect it's a related but different problem.
 

mikelove

皇帝
Staff member
#7
Sorry, I wasn't clear enough in my previous post - it's not in a format that Calibre or anything else would be able to read, it may have a .pdb extension but it's proprietary to Pleco.

As far as it not opening in general, I'm afraid we couldn't dig up much from your device details. For bug reporting, go into Settings / Device Options and tap on the serial number twice and that should make the Developer Options section in Settings show up; there should be a 'take bug report' command in there.
 
#8
Thanks for the clarification - I'll see if I can't report the bug and get Amazon to do something about it. Assuming the full book is in the same format as the demo, I guess I'll wait to order it until/unless I'll actually be able to read it. ;)

Or not. :( It appears Amazon isn't interested in its Developers reporting bugs; I opened the "Developer Options" menu as you suggested and the closest thing I could find to a bug report option was "select debug app" - with those options being "Amazon Facebook Share" and "Manage Social Networks." I guess I'll see if there's a Fire forum at Amazon that can be of assistance.

Survey says: no. :rolleyes: So, I guess I'll wait until the next OS and/or Pleco release and see if it inadvertently fixed the problem. Barring that, I can always order the hardcopy 4th Edition, I suppose.
 
Last edited:

mikelove

皇帝
Staff member
#9
That's odd... so nothing about taking bug reports in there? Seems like a weird feature for Amazon to remove.

The full book is indeed in the same format as the demo.
 
#11
A positive development - earlier today I deleted the demo, and wasn't sure when to try again. During dinner, I noticed my Kindle Fire was doing a system update, so when that finally wrapped itself up I downloaded the demo again, crossed my fingers ... lo and behold, it opened properly. :D I'm not sure which action or combination got it working, but at least for the time being it's readable, and very interesting to boot.
 
Top