No longer able to hear Cantonese pronunciation

I'm new to this forum, and to using Pleco.
I'm using Pleco for Android, version 3.2.33. Last week, I was able to click on the audio for Cantonese pronunciation (which I had never done before) and I heard it in Cantonese. I was thrilled to be able to learn some new phrases. However, something happened (not quite sure what it was) and now, every time I click on the audio pronunciations, it's always in Mandarin. Can anyone help me figure how I may have (inadvertently) turned off the Cantonese audio, or if something else is wrong?


Staff member
Hmm... is this happening even when you click on the button next to the Cantonese reading? Go the Pleco "Settings" screen / Audio and try turning on "alternate Cantonese locale"; does that help matters any? If not, go back into that same screen / System TTS Settings, set your default language in Google TTS settings to "Cantonese (Hong Kong)", then go back to "Text-to-speech settings" and tap "Listen to an example"; does Cantonese audio play correctly then?

If not, the issue is unfortunately in Google TTS, which has gotten very buggy lately in general - best bet would probably be to download an alternate Cantonese TTS from Google Play, like Ekho, and select that as the engine for Pleco TTS to use instead (Settings / Audio). We are working on getting a high-quality paid Cantonese TTS that we can sell in Add-ons and hope to have that available by early next year, but for now we're reliant on outside engines like Google's.
Thanks for the advice. The first few things didn't help (changing the Google TTS settings) so I eventually downloaded Ekho and it works now. Thanks!